Donations via PayPal are welcome:
Click here to launch FFGenie 2014.3

FFGenie 2014.3 requires Java 7 or higher. Please download Java from http://www.java.com

Q: I'm having trouble launching FFGenie 2014.3. There's a dialog appearing warning me about self-signed applications?

A: Ever since Java Update 21, the paranoid folks at Oracle have decided that self-signing applications are a big no-no.
There is a way to get around this restriction.

  1. For Windows users, open "Control Panel" and then double-click on "Java".
  2. Go to the "Security" tab and press the "Edit Site List..." button.
  3. Click "Add" and then edit the row in the "Location" table to http://ffgenie.com (Important: no www)
  4. Press OK and OK to close the dialogs.

Now when you launch FFGenie 2014.3, there will be a warning dialog. Just tick the checkbox and press OK to continue.